Issue adding emails to boxes
Incident Report for Streak
Resolved
This incident has been resolved. We understand this may have been disruptive to your workflow and we appreciate your patience.
Posted Apr 21, 2020 - 18:56 UTC
Monitoring
We've identified the issue and a potential fix has been implemented. We're monitoring results and will share another update within 30 minutes.

We appreciate your patience.
Posted Apr 21, 2020 - 18:45 UTC
Investigating
We're currently investigating an issue with adding emails to boxes.

We know this affects your work and we apologize for the inconvenience. We take this very seriously and will have an update within 30 minutes.
Posted Apr 21, 2020 - 18:10 UTC
This incident affected: Streak for Gmail (desktop).