Streak service interruption
Incident Report for Streak
Resolved
This incident has been resolved - please refresh your browser to continue using Streak. We apologize for the disruption and appreciate your patience.
Posted Oct 30, 2019 - 14:49 UTC
Investigating
We're currently experiencing an interruption in Streak's performance and are investigating the issue. We'll post an update here within 30 minutes or sooner. We apologize for the inconvenience.
Posted Oct 30, 2019 - 14:32 UTC
This incident affected: Streak API, Streak for Gmail (desktop), Streak for Android, and Streak for iOS.