Boxes slow to load
Incident Report for Streak
Resolved
This incident has been resolved.
Posted Feb 27, 2023 - 20:28 UTC
Monitoring
Please give your Streak a refresh. While we are still monitoring the issue, we believe the box load times should not be affected anymore. Reach to support@streak.com if you continue to experience load issues.
Posted Feb 27, 2023 - 18:00 UTC
Identified
We've identified an issue with boxes loading and our engineers are working on fixing the underlying issue. Thanks for your patience. We will update here once the issue is resolved.
Posted Feb 27, 2023 - 17:18 UTC
This incident affected: streak.com.