Streak is slow to load or not responsive on certain features

Incident Report for Streak

Resolved

We've identified the issue and pushed a fix. If you continue to experience any slowness or anything else, please reach out to support@streak.com.
Posted Aug 25, 2025 - 22:14 UTC

Update

We are continuing to investigate this issue.
Posted Aug 25, 2025 - 22:13 UTC

Investigating

Our team is investigating the reason for this slowdown and will continue to post updates here as we are made aware of what's causing this performance blip. If you are unable to add an emails to a box or see issues with comments on a box, or any other performance issues, we are looking into the cause of those now.
Posted Aug 25, 2025 - 21:50 UTC
This incident affected: streak.com.