Degraded sidebar performance
Incident Report for Streak
Resolved
We've identified the cause of the issue and released a fix.
Posted Jan 03, 2020 - 21:06 UTC
Investigating
We are currently investigating an issue that may cause the some email threads to not appear to have been added to Streak.
Posted Jan 03, 2020 - 20:27 UTC
This incident affected: streak.com and Streak for Gmail (desktop).