Streak mail merge and email tracking not loading
Incident Report for Streak
Resolved
This incident has been resolved. We appreciate your patience with us today!
Posted Sep 12, 2022 - 19:53 UTC
Update
We are continuing to monitor any further issues. We're currently working on re-populating the email tracking folders under the Sent view.
Posted Sep 12, 2022 - 19:28 UTC
Monitoring
A fix has been implemented for the outstanding issues and we're currently monitoring the results. A refresh of your Gmail page will be required for the latest update to apply.
Posted Sep 12, 2022 - 18:03 UTC
Update
The mail merge loading issue has been resolved. Please refresh your Gmail page for the latest update to apply. We are still working on resolving the email tracking and boxed emails issues. We will provide another update once these two issues have been fixed.
Posted Sep 12, 2022 - 17:21 UTC
Identified
The issue has been identified and a fix is being implemented. We will continue to provide status updates once a fix has been released. We appreciate your patience while we work on resolving this issue.
Posted Sep 12, 2022 - 16:34 UTC
Investigating
Our team is currently investigating an issue affecting mail merge, email tracking, and boxed emails. We'll provide status updates once we have any additional information. Apologies for the inconvenience.
Posted Sep 12, 2022 - 14:20 UTC
This incident affected: Streak for Gmail (desktop).