Slow permformance

Incident Report for Streak

Resolved

Our engineering team have isolated the cause and have implemented a fix.

Thank you for your patience while this was being looked into.
Posted Mar 18, 2026 - 11:50 UTC

Update

We are continuing to investigate this issue.
Posted Mar 18, 2026 - 11:47 UTC

Investigating

We're currently investigating an issue causing pipelines to take several minutes to load.

This is currently affecting a small percentage of users as of 11:04 (GMT).

We apologize for the inconvenience and will post an update here within 30 minutes or as soon as we have any information.
Posted Mar 18, 2026 - 11:12 UTC
This incident affected: Streak for Gmail (desktop).