Streak boxes loading slowly
Incident Report for Streak
Resolved
We've resolved the issue causing a Streak service interruption and everything should be functioning as normal. We apologize for the interruption today and truly appreciate your patience!
Posted Nov 29, 2021 - 19:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 29, 2021 - 19:24 UTC
Identified
Our team has identified the issue and we're currently working on implementing a fix. We'll continue to provide any updates once the issue has been resolved.
Posted Nov 29, 2021 - 18:08 UTC
Investigating
We're currently investigating an issue causing boxes to take several minutes to load. We apologize for the inconvenience and will post an update here as soon as we have more information.
Posted Nov 29, 2021 - 15:30 UTC
This incident affected: Streak for Gmail (desktop).