Slow loading times

Incident Report for Streak

Resolved

This incident has been resolved.
Posted May 17, 2021 - 15:44 UTC

Update

We believe we've fixed the root cause and are monitoring systems to confirm.
Posted May 17, 2021 - 15:19 UTC

Update

We are continuing to investigate the issue. We'll update asap or in 30 minutes.
Posted May 17, 2021 - 15:02 UTC

Update

We are continuing to investigate this issue.
Posted May 17, 2021 - 14:33 UTC

Investigating

We are actively investigating reports of slow loading times. We'll update ASAP or in 30 minutes.
Posted May 17, 2021 - 14:33 UTC
This incident affected: streak.com, Streak API, Streak for Gmail (desktop), Streak for Android, and Streak for iOS.