Unable to add contacts to boxes
Incident Report for Streak
Resolved
Contacts should now load as expected once your Gmail page has been refreshed. We appreciate your patience with us and apologize for the inconvenience today.
Posted May 10, 2023 - 20:52 UTC
Monitoring
A fix has been implemented and we're currently monitoring the results. A refresh of your Gmail will be required for the fix to apply. Please reach out to support@streak.com if the issue persists after a refresh.
Posted May 10, 2023 - 20:47 UTC
Investigating
We are currently investigating an issue affecting contacts from being added to boxes. We apologize for the inconvenience and we'll provide an update once we have more information.
Posted May 10, 2023 - 20:18 UTC
This incident affected: Streak for Gmail (desktop).