Issue saving edits to boxes
Incident Report for Streak
Resolved
This incident has been resolved and is no longer affecting box edits. We sincerely apologize for any inconvenience this caused and appreciate your patience as we worked on a fix!
Posted Jun 30, 2020 - 18:43 UTC
Update
Although we have alleviated the symptoms impacting most users, we are continuing to work on a long-term fix for this issue. We appreciate your patience and will post another update within 30 minutes.
Posted Jun 30, 2020 - 18:07 UTC
Identified
We've implemented measures to alleviate the current issue as we continuing investigating a longer term fix. We understand issues like these affect your work and we truly apologize. We appreciate your patience as we work to resolve the issue.
Posted Jun 30, 2020 - 17:31 UTC
Investigating
We've identified an issue where some edits to your boxes in Streak aren't saving. The issue started around 8:40am PST. We're currently investigating and will post an update within 30 minutes.
Posted Jun 30, 2020 - 16:55 UTC
This incident affected: Streak for Gmail (desktop).