Degraded email thread performance

Incident Report for Streak

Resolved

This incident has been resolved.
Posted May 28, 2026 - 23:26 UTC

Identified

We've detected a slowdown in the automatic adding of email threads to Streak. We're working on a fix and are monitoring the performance.
Posted May 28, 2026 - 17:24 UTC
This incident affected: streak.com.