Streak outage impacting multiple features
Incident Report for Streak
Resolved
This incident has been resolved. If you're still experiencing issues, please refresh your browser window. If issues persist after a refresh, please reach out to our support team so we can investigate.

Thanks for your patience as we got things back on track!
Posted Feb 17, 2024 - 01:17 UTC
Investigating
We're currently investigating an outage impacting multiple Streak features, such as boxed email threads and other CRM features in Gmail.

We'll have an update in 30 minutes or as soon as we have more information to share.

We apologize for the inconvenience and are working to resolve this as soon as possible.
Posted Feb 17, 2024 - 01:00 UTC
This incident affected: Streak for Gmail (desktop).