Service Issue
Incident Report for Streak
Resolved
This incident has been resolved.
Posted Jul 22, 2020 - 04:06 UTC
Monitoring
We believe the service issue has been mitigated and monitoring performance.
Posted Jul 21, 2020 - 23:55 UTC
Investigating
We're looking into reports of issues with Streak service.
Posted Jul 21, 2020 - 23:42 UTC
This incident affected: streak.com, Streak API, Streak for Gmail (desktop), Streak for Android, and Streak for iOS.