Box timeline errors
Incident Report for Streak
Resolved
Our engineering team has implemented a fix and the box timeline has been restored. The error affected 1% of our user base. We appreciate the patience everyone shared with us during the outage. ♥
Posted Dec 09, 2019 - 21:16 UTC
Investigating
Streak is investigating an outage related to box timelines. We're deeply sorry for the trouble this is causing and will have an update in 30 mins.
Posted Dec 09, 2019 - 18:59 UTC
This incident affected: Streak for Gmail (desktop).