Boxed Email Threads Not Visible Inside of Boxes
Incident Report for Streak
Resolved
This incident has been resolved.
Posted Nov 22, 2021 - 21:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 22, 2021 - 17:42 UTC
Update
We're fixing an issue that prevented emails that were added to Streak from being processed. Any emails added to Streak since 6am PST Nov 21 are affected. A fix is in place but it will take several hours to fully resolve. Thank you for your patience!
Posted Nov 22, 2021 - 16:52 UTC
Investigating
Streak is experiencing an issue with boxed email threads being visible and accessible from inside of boxes. We apologize for the issue this morning and will post updates periodically.
Posted Nov 22, 2021 - 15:28 UTC