Delays with email threads and automatic email sharing being added to boxes
Incident Report for Streak
Resolved
This incident has been resolved. If you're still encountering any issues, please reach out to us at support@streak.com.
Posted Nov 16, 2023 - 21:58 UTC
Monitoring
A fix has been implemented and we're starting to see some recovery. Your email threads should start populating shortly and any pending mail merges will begin sending. The estimated completion for full recovery is at around 12:45 PM PST. We appreciate your patience!
Posted Nov 16, 2023 - 19:54 UTC
Investigating
We are currently investigating an issue preventing email threads from populating in Streak boxes. This also includes emails automatically being added to boxes from the automatic email sharing feature (include all emails). We apologize for the inconvenience and will share an update when as fix has been implemented.
Posted Nov 16, 2023 - 19:03 UTC
This incident affected: Streak API and Streak for Gmail (desktop).