Performance issues, including saving box edits
Incident Report for Streak
Resolved
This issue has been resolved - we apologize again for any inconvenience that this caused and appreciate your patience.
Posted Dec 09, 2020 - 20:19 UTC
Update
We apologize for the disruption today - we have implemented a fix that appears to have resolved the issue, but we'll continue to monitor the situation and update with any additional information. Thank you for your patience - we know this affects your workflow and take this very seriously.
Posted Dec 09, 2020 - 19:37 UTC
Update
We're continuing to work on a permanent fix for this issue and apologize for any continued disruption that hasn't yet been resolved. We'll post an update within 30 minutes.
Posted Dec 09, 2020 - 19:07 UTC
Monitoring
We've identified an issue with our cloud provider - we implemented a workaround and will continue monitoring the situation. We sincerely apologize for the disturbance - we know this affects your work.
Posted Dec 09, 2020 - 18:24 UTC
Investigating
We're investigating an issue that caused some box edits - like saving a comment, changing a stage, or boxing an email - not to save. It appears that this only affected users briefly, but we're still examining how widespread this issue is/was. We will follow up with an update within 30 minutes or when we have more information. We apologize to anybody experiencing this issue!
Posted Dec 09, 2020 - 18:07 UTC
This incident affected: streak.com and Streak for Gmail (desktop).