Issue saving content to box timeline
Incident Report for Streak
Resolved
This incident has been resolved and we've restored the ability to save content to box timelines. We apologize for the inconvenience!
Posted Dec 15, 2020 - 22:27 UTC
Investigating
We're currently investigating an issue with saving content (comments, tasks, call logs, meeting notes) to the box timeline. We apologize for the inconvenience and will share an update within 30 minutes or as soon as we have more information.
Posted Dec 15, 2020 - 21:58 UTC
This incident affected: Streak for Gmail (desktop).