Delays loading data in Streak
Incident Report for Streak
Resolved
The issue causing delayed loading for boxes and data in Streak has been resolved. We apologize for the disruption and appreciate your patience as we worked on a fix.
Posted Jul 27, 2020 - 21:37 UTC
Investigating
We're currently investigating an issue that may cause delays loading data in Streak and via the Streak API. We know this affects your workflow - we truly apologize for the inconvenience and will post an update within 30 minutes as we work to resolve the issue.
Posted Jul 27, 2020 - 21:03 UTC
This incident affected: Streak API and Streak for Gmail (desktop).