Streak Outage
Incident Report for Streak
Resolved
This incident has been resolved.
Posted May 01, 2021 - 15:33 UTC
Monitoring
We've implemented a fix and are monitoring.
Posted May 01, 2021 - 15:31 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 01, 2021 - 15:31 UTC
Investigating
We are currently investigating an issue with our SSL certificate that may cause Streak to not load or respond.
Posted May 01, 2021 - 14:28 UTC
This incident affected: streak.com, Streak API, Streak for Gmail (desktop), Streak for Android, and Streak for iOS.