Outage
Incident Report for Streak
Resolved
We've fixed the cause of the outage and Streak is up for all users now. Thank you for your patience!
Posted Feb 14, 2020 - 01:14 UTC
Investigating
Streak is experiencing slowdowns for some of our users and might not load.

We apologize for the interruption of service and will be updating you as we know more.
Posted Feb 14, 2020 - 00:46 UTC
This incident affected: streak.com, Streak API, Streak for Gmail (desktop), Streak for Android, and Streak for iOS.