Streak not loading, issues saving box edits
Incident Report for Streak
Resolved
This incident has been resolved. Streak experienced elevated error rates from 11:37 am ET - 12:11 pm ET which prevented Streak from loading and caused issues with boxes loading.
Posted Mar 11, 2021 - 17:33 UTC
Monitoring
We are monitoring an issue preventing Streak from loading due to elevated error rates starting at 11:37 am ET. We apologize for the interruption.
Posted Mar 11, 2021 - 17:03 UTC
This incident affected: streak.com, Streak API, Streak for Gmail (desktop), Streak for Android, and Streak for iOS.