Streak boxes not loading
Incident Report for Streak
Resolved
This incident has been resolved.
Posted Oct 09, 2023 - 18:32 UTC
Monitoring
A fix has been implemented and we're currently monitoring the results. Please reach out to us at support@streak.com if you're still encountering any loading issues.
Posted Oct 09, 2023 - 18:22 UTC
Update
We are continuing to investigate this issue.
Posted Oct 09, 2023 - 17:51 UTC
Investigating
We're currently investigating an issue preventing Streak boxes from loading. We apologize for the inconvenience and will post an update here as soon as we have more information.
Posted Oct 09, 2023 - 17:50 UTC
This incident affected: Streak for Gmail (desktop).